hdu5980_Find Small A_思维

Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai ≤2^32 - 1) follow
 

Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.
 

Sample Input
   
   
3 97 24929 100
 

Sample Output
   
   
3

题意:
任意一个int型的数都是32位,问你以8位表示的数里有几个97。
解:
任意一个int都是32位,每个int有四个8位组成,就将 各个8位拆出来,查找每位上是否是97就行。
分别除余256,256*256,256*256*256,256*256*256*256就行。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn=1500000;
int m[maxn];
int w0=1,w1=256,w2=256*256,w3=256*256*256;
int main()
{
  int n;int sum;
  while(~scanf("%d",&n))
  {
      sum=0;
      for(int i=0;i<n;i++)
      {
          scanf("%d",&m[i]);
      }
      for(int i=0;i<n;i++)
      {
            int temp=0;
            temp=m[i]/w3;
            if(temp==97)sum++;
            m[i]%=w3;

            temp=m[i]/w2;
            if(temp==97)sum++;
            m[i]%=w2;

            temp=m[i]/w1;
            if(temp==97)sum++;
            m[i]%=w1;

            temp=m[i]/w0;
            if(temp==97)sum++;
            m[i]%=w0;
      }

      printf("%d\n",sum);

  }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值