Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported:
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
QUIT: Quit the browser.
Assume that the browser initially loads the web page at the URL http://www.acm.org/
Input
Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.
Output
For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.
Sample Input
VISIT http://acm.ashland.edu/ VISIT http://acm.baylor.edu/acmicpc/ BACK BACK BACK FORWARD VISIT http://www.ibm.com/ BACK BACK FORWARD FORWARD FORWARD QUIT
Sample Output
http://acm.ashland.edu/ http://acm.baylor.edu/acmicpc/ http://acm.ashland.edu/ http://www.acm.org/ Ignored http://acm.ashland.edu/ http://www.ibm.com/ http://acm.ashland.edu/ http://www.acm.org/ http://acm.ashland.edu/ http://www.ibm.com/ Ignored
用两个栈存一下,第一个是后退栈,第二个是前进栈。
如果当前显示后退,那么把后退栈中的顶部元素弹到前进栈中,然后输出当前的顶部元素,如果只有一个元素了,那么就显示忽略指令。
如果当前显示前进,那么把前进栈中的顶部元素输出并弹到后退栈中,如果没有元素了,那么就忽略指令。
如果当前显示访问,那么把前进栈清空,并把此网站输出后存到后退栈中。
#include<iostream>
#include<cstring>
#include<algorithm>
#include<map>
#include<string>
#include<set>
#include<sstream>
#include<queue>
#include<cstdio>
#include<stack>
using namespace std;
int main()
{
stack<string>backstack,forwardstack;
while(backstack.size())
backstack.pop();
while(forwardstack.size())
forwardstack.pop();
backstack.push("http://www.acm.org/");
string commend;
while(cin>>commend)
{
if(commend == "VISIT")
{
string temp;
cin>>temp;
cout<<temp<<endl;
backstack.push(temp);
while(forwardstack.size())
forwardstack.pop();
}
else if(commend == "BACK")
{
if(backstack.size()==1)
printf("Ignored\n");
else
{
string temp = "";
temp += backstack.top();
forwardstack.push(temp);
backstack.pop();
cout<<backstack.top()<<endl;
}
}
else if(commend == "FORWARD")
{
if(!forwardstack.size())
printf("Ignored\n");
else
{
cout<<forwardstack.top()<<endl;
string temp = "";
temp += forwardstack.top();
backstack.push(temp);
forwardstack.pop();
}
}
else
break;
}
return 0;
}