HDU 1789 Doing Homework again (贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6441    Accepted Submission(s): 3829



Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 
题目大意:给定一系列任务的截至时间 和无法完成的罚分
解题思路:第N天截至的只能在前N天完成 对于第N天截至的任务 最多只能有N个
超出的必然无法完成 所以对于第N天截至的任务 如果超过N个 那么保留前N大的
后面的必然要罚分 然后从最后一天开始 所有截至日期大于当天的中的罚分最多的任务在当天完成
剩下的继续在下一天继续比较 在开始的时候记录总是罚分cur  用cur减去每次完成的任务的罚分
最后cur即是总是罚分
先按照扣分从大到小排序,分数相同则按照截止日期从小到大排序。。
然后按顺序,从截止日期开始往前找没有占用掉的时间。
如果找不到了,则加到罚分里面
代码:46MS
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define M 1000
#define N 100
struct node{
int time,s;
}dp[M];
bool cmp(node x,node y)
{
    if(x.s==y.s)
    return x.time<y.time;
    return x.s>y.s;
}
int map[M];
int main()
{
    int i,j,n,m;
    cin>>m;
    while(m--)
    {
        cin>>n;
        int cur=0;
        memset(map,0,sizeof(0));
        for(i=0;i<n;i++) cin>>dp[i].time;
        for(i=0;i<n;i++) cin>>dp[i].s;
        sort(dp,dp+n,cmp);
        memset(map,0,sizeof(map));
        for(i=0;i<n;i++)
        {
        for(j=dp[i].time;j>0;j--)
        {
          if(!map[j]) {map[j]=1;break;}
        }
        if(j==0) cur+=dp[i].s;
        }
        cout<<cur<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值