DP--分组背包--HDU - 1712

Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit? 
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. 
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. 
N = 0 and M = 0 ends the input. 
 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain. 
 

Sample Input

    
    
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output

    
    
3 4 6


分析:分组背包,就是第n门课程,可以做一天,可以做两天,但它们相斥,你做了一天,就不能再做一天

分组背包的基本套路是这样的:

有N件物品和一个容量为V的背包。第i件物品的费用是Ci,价值是Wi 。这些物品被划分为 K
组,每组中的物品互相冲突,最多选一件。求解将哪些物品装入背包可使这些物品的费用总和
不超过背包容量,且价值总和最大。 


这个问题变成了每组物品有若干种策略:是选择本组的某一件,还是一件
都不选。也就是说设 F [k, v] 表示前 k 组物品花费费用 v 能取得的最大权值,则
有:
        F [k, v] = max {F [k − 1, v], F [k − 1, v − Ci ] + Wi | item i ∈ group k}
使用一维数组的伪代码如下:
        for k = 1 to K
          for v = V to 0
            for item i in group k
                F [v] = max {F [v], F [v − Ci ] + Wi }
这里三层循环的顺序保证了每一组内的物品最多只有一个会被添加到背包中。


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 110;
int A[maxn][maxn], dp[maxn];

int main()
{
	int n, m;
	while(scanf("%d%d", &n, &m), n) {
		for(int i=0; i<n; i++)
			for(int j=0; j<m; j++)
				scanf("%d", &A[i][j]);
		memset(dp, 0, sizeof(dp));
		for(int i=0; i<n; i++)
			for(int v=m; v>0; v--)
				for(int j=0; j<m; j++)
					if(v > j) dp[v] = max(dp[v], dp[v-j-1] + A[i][j]);
		printf("%d\n", dp[m]);
	}
    return 0;
}


评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值