POJ - 1330 Nearest Common Ancestors

Nearest Common Ancestors

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:

In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

思路:

这是lca问题,就是找最近公共祖先节点,由于至多有10^4个,算法的复杂度为O(n),直接暴力。先计算两个节点的深度,让深度较大的往上直至深度相同,这时若父节点相同则为所求,否则同是往上,直到求出lca。

代码:

#include <iostream>
#include <cstring>
using namespace std;

const int maxn=10010;
int A[maxn];

int main() {
	int cas;
	cin>>cas;
	
	while(cas--){
		memset(A,0,sizeof(A));
		
		int n;
		cin>>n;
		
		for(int i=0;i<n-1;i++){
			int x,y;
			cin>>x>>y;
			A[y]=x;		//题目规定了第一个数是第二个数的父亲节点 
		} 
		
		//int root=1;
		//while(A[root]){
		//	root++;
		//}
		
		int a,b;
		cin>>a>>b;
		
		//朴素法
		//计算这两个节点的深度d1,d2
		int d1=1,d2=1,p=a;		//中间节点p 
		while(A[p]){
			p=A[p];
			d1++;
		} 
		p=b;
		while(A[p]){
			p=A[p];
			d2++;
		}
		
		//cout<<endl<<d1<<' '<<d2<<endl;
		//lca
		while(d1>d2){
			a=A[a];
			d1--;
		}
		while(d1<d2){
			b=A[b];
			d2--;
		} 
		//d1==d2
		//cout<<endl<<a<<' '<<b<<endl;
		
		if(b==a){
			cout<<b<<endl;
			continue;
		} 
		while(A[a]!=A[b]){
			a=A[a];
			b=A[b];
		} 
		
		cout<<A[a]<<endl;
		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

u小鬼

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值