HDOJ 2052 Picture

324 篇文章 134 订阅
286 篇文章 0 订阅

Problem Description
Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input
3 2

Sample Output
+---+
|   |
|   |
+---+

别忘了每一个输出后面空一行

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int m = sc.nextInt();
            int n = sc.nextInt();

            for(int i=0;i<n+2;i++){

                for(int j=0;j<m+2;j++){
                    if(i==0){
                        if(j==0||j==m+1){
                            System.out.print("+");
                        }else{
                            System.out.print("-");
                        }
                    }else if(i==n+1){
                        if(j==0||j==m+1){
                            System.out.print("+");
                        }else{
                            System.out.print("-");
                        }
                    }else {
                        if(j==0||j==m+1){
                            System.out.print("|");
                        }else{
                            System.out.print(" ");
                        }
                    }
                }
                System.out.println();
            }
            System.out.println();

        }


    }

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

谙忆

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值