POJ 4355 Party All the Time(三分)

Party All the Time




Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )
 

Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

Sample Input
  
  
1 4 0.6 5 3.9 10 5.1 7 8.4 10
 

Sample Output
  
  
Case #1: 832
题目大意:在x轴上分布着一群人,每个人有一个重量w。现在他们要去参加一个聚会,但是他们都很懒,如果走的太远的话就会很烦恼,这个值等于体重与走动距离3次方的乘积。现在知道每个人的坐标和体重,求每个人烦恼值之和的最小值。

解题思路:根据数学知识可以知道烦恼值之和是关于距离的一个单峰函数,所以可以用三分法求解。注意三分的精度,使得ub - lb > 1e-4即可达到题目要求。

代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>

typedef long long ll;
const int maxn = 50055;
const double EPS = 1e-4;

struct node{
    double d;
    double w;
};
struct node spirit[maxn];
int n;


double cal(double dis)
{
    double res = 0;
    int i;
    for(i = 0;i < n;i++){
        res += pow(fabs(dis - spirit[i].d),3.0) * spirit[i].w;
    }
    return res;
}

int main()
{
    int t,ncase;
    scanf("%d",&t);
    ncase = 0;
    while(t--){
        scanf("%d",&n);
        int i;
        for(i = 0;i < n;i++){
            scanf("%lf %lf",&spirit[i].d,&spirit[i].w);
        }
        double lb,lm,um,ub;
        lb = spirit[0].d;
        ub = spirit[n - 1].d;
        while(ub - lb > EPS){
            lm = (lb + ub) / 2;
            um = (lm + ub) / 2;
            if(cal(lm) < cal(um))
                ub = um;
            else
                lb = lm;
        }
        printf("Case #%d: %.f\n",++ncase,cal(lb));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值