POJ 1651 Multiplication Puzzle(区间DP)

Multiplication Puzzle

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650
题目大意:有一排卡片,每个卡片上有一个大于等于1且小于等于100的整数。每次从这一排卡片中抽出一张卡片,得到的分数为这张卡片上的数字与左右两边卡片上的数字之积,第一张卡片和最后一张卡片不能被抽走。重复抽取操作直到还剩下2张卡片为止,求得到的分数的最小值。

解题思路:矩阵链乘的模型,状态转移方程与矩阵链乘相似。定义dp[i][j]为第i张与第j张卡片之间的得分最小值,则dp[i][j] = min(dp[i][k] + dp[k][j] + num[i] * num[k] * num[j])。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <climits>

using namespace std;

const int maxn = 105;

int num[maxn],dp[maxn][maxn];

int main()
{
    int n;
    while(scanf("%d",&n) != EOF){
        for(int i = 1;i <= n;i++){
            scanf("%d",&num[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int l = 2;l <= n - 1;l++){
            for(int i = 1;i <= n - l;i++){
                int j = i + l;
                dp[i][j] = INT_MAX;
                for(int k = i + 1;k < j;k++){
                    dp[i][j] = min(dp[i][j],dp[i][k] + dp[k][j] + num[i] * num[k] * num[j]);
                }
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值