HDU 1164 Eddy's research I 素数因子

原题 http://acm.hdu.edu.cn/showproblem.php?pid=1164

题目:

Eddy’s research I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7687 Accepted Submission(s): 4674

Problem Description
Eddy’s interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can’t write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

Output
You have to print a line in the output for each entry with the answer to the previous question.

Sample Input
11
9412

Sample Output
11
2*2*13*181

思路:

对任意一个数,将他分解成素数的乘积按格式输出。

此题用到了队列,队列可以很简单的存储数据。empty函数会是使得输出格式变得很容易。
此题首先将n的所有素数因子2取出来,并压入队列,再将n/2,这样的n将是一个奇数,我们只需要再从3开始寻找因子,并且每个因子都是奇数,所以i=i+2会将用时再减小一半。
队列先进先出可以很轻松让结果从小到大输出。

代码:

#include <iostream>
#include"stdio.h"
#include"queue"
using namespace std;

int main()
{
    int x;
    while(scanf("%d",&x)!=EOF)
    {
        queue <int> q;
        int i=2;
        while(x%2==0)
        {
            q.push(i);
            x=x/2;
        }
        for(i=3;i*i<=x;)
        {
            if(x%i!=0)
            {
                i=i+2;
            }
            else
            {
                q.push(i);
                x=x/i;
            }
        }
        q.push(x);
        while(!q.empty())
        {
            int y;
            y=q.front();
            printf("%d",y);
            q.pop();
            if(!q.empty())
            {
                printf("*");
            }
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值