solution Of 1106. Lowest Price in Supply Chain (25)

48 篇文章 0 订阅

1106. Lowest Price in Supply Chain (25)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2


结题思路 :
题意要求我们计算找到可以后的最低价格的零售商的价格和这个价格的零售商的个数。
要求1:每个中间商或零售商只有一个上游卖家;
要点2:index=0作为生产商;
要点3:供应链中不存在环路。

程序步骤:
第一步、初始化,建立索引关系;
第二步、对每个没有下游买家的零售商求取他们距离生产商经过了几个中间商。
第三部、找到零售商的集合中距离生产商最近的零售商个数。


具体程序(AC)如下:

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <cmath>
using namespace std;
int parent[100005];
int depth[100005];
vector<int> retailers;
int getDepth(int site)
{
    if(site==0)
        return 0;
    int pa=parent[site];
    if(depth[pa]!=-1)
        return depth[site]=depth[pa]+1;
    return depth[site]=getDepth(pa)+1;
}
int main()
{
    int num;
    double priceRoot;
    double rate;
    cin>>num>>priceRoot>>rate;
    memset(parent,-1,sizeof(parent));
    memset(depth,-1,sizeof(depth));
    depth[0]=0;//root
    retailers.clear();
    int childNum,child;
    for(int i=0;i<num;++i)
    {
        cin>>childNum;
        if(childNum==0)
            retailers.push_back(i);
        for(int j=0;j<childNum;++j)
        {
            cin>>child;
            parent[child]=i;
        }
    }
    int min=100005;
    int availab=0;
    for(int i=0;i<retailers.size();++i)
    {
        depth[retailers[i]]=getDepth(retailers[i]);
        if(depth[retailers[i]]<min)
        {
            min=depth[retailers[i]];
            availab=1;
        }
        else if(depth[retailers[i]]==min)
            ++availab;
    }
    rate=pow(1+rate/100,min);
    printf("%.4lf %d\n",priceRoot*rate,availab);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值