HDU 5620 KK's Steel(思维题)

109 篇文章 0 订阅
16 篇文章 0 订阅

KK’s Steel

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 737 Accepted Submission(s): 345

Problem Description
Our lovely KK has a difficult mathematical problem:he has a N(1≤N≤1018) meters steel,he will cut it into steels as many as possible,and he doesn’t want any two of them be the same length or any three of them can form a triangle.

Input
The first line of the input file contains an integer T(1≤T≤10), which indicates the number of test cases.

Each test case contains one line including a integer N(1≤N≤1018),indicating the length of the steel.

Output
For each test case, output one line, an integer represent the maxiumum number of steels he can cut it into.

Sample Input
1
6

Sample Output
3

Hint
1+2+3=6 but 1+2=3 They are all different and cannot make a triangle.

Source
BestCoder Round #71 (div.2)

题意:给出一个钢管,你可以把它拆分为任意个数,并且要满足一下要求。
应该满足的条件为:
1.这组数的任意两个数都不相等。
2.并且任意三个不能形成三角形。
问你可以分为多少个数
求出划分的个数。
首先从6开始推起,6可以划分为1,2,3。
7的话可以划分为1,2,4。
8的话可以分为1,2,5。
9的话可以分为1,2,6。
10的话可以分为2,3,5或者1,4,5。
11的话可以分为1,2,3,5。4个
相信到现在大家应该可以发现规律了,如果还没有发现的话,可以先看下代码。
下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

long long a[200];
long long b[200];
void init()
{
    a[1]=1;
    a[2]=2;
    for(int i=3;i<=200;i++)
    {
        a[i]=a[i-1]+a[i-2];
    }
    long long sum=0;
    for(int i=1;i<=200;i++)
    {
        sum+=a[i];
        b[i]=sum;
    }
}
int main()
{
    int t;
    init();
    scanf("%d",&t);
    while(t--)
    {
        long long n;
        scanf("%lld",&n);
        int flag=0;
        for(int i=1;i<190;i++)
        {
            if(b[i]==n)
            {
                flag=i;
                break;
            }
            else if(b[i]>n)
            {
                flag=i-1;
                break;
            }
        }
        if(flag<3)
        {
            flag=0;
        }
        printf("%d\n",flag);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值