poj3259 Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 43774 Accepted: 16073

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

虫洞,这个题就是说一个人在农场突然发现了一些虫洞,于是便想着能不能从某点出发回到原点并且还是回到了以前,告诉你N点数,M路径数,W冲动数。

不难理解,把话费的时间看做权值,而虫洞的显然是负值。就是判断一下会不会产生负环。因为点数不是很大,并且给了两秒,所以直接用floyd写了,过了。

其实有个略小的优化╮(╯▽╰)╭

不然是水不过去的,想要看优先队列做法的,直接参照poj1860那个题是判断正环的。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
#include <string>
#include <cstring>
#include <cmath>
#include <queue>

using namespace std;
const int inf=0x3f3f3f;
int n,m,p;
int dis[520][520];
int floyd()
{
    int i,j,k;
    for(k=1; k<=n; ++k)
        for(i=1; i<=n; ++i)
        {
            for(j=1; j<=n; ++j)
            {
                if(dis[i][j]>dis[i][k]+dis[k][j])
                {
                    dis[i][j]=dis[i][k]+dis[k][j];
                }
            }
            if(dis[i][i]<0)return 1;//只要找到负环接着返回
        }
            return 0;
}
int main()
{
    int t;
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&p);
        for(i=1; i<=n; ++i)
            for(j=1; j<=n; ++j)
            {
                if(i==j)dis[i][j]=0;
                else dis[i][j]=inf;
            }
        int u,v,w;
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&w);
            if(w<dis[u][v])
            {
                dis[u][v]=dis[v][u]=w;
            }
        }
        while(p--)
        {
            scanf("%d%d%d",&u,&v,&w);
            dis[u][v]=-w;
        }
        if(floyd())printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值