1101 Quick Sort (25 point(s))

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given Ndistinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

参考代码:

#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 100010;
int INF = 0x7fffffff;
int A[maxn], leftMax[maxn] ,rightMin[maxn], ans[maxn];


int main(){
    int n;
    scanf("%d", &n);
    for (int i = 0; i < n; ++i) {
        scanf("%d", &A[i]);
    }

    leftMax[0] = 0;//A[0]左边没有比它更小的数
    for (int j = 1; j < n; ++j) {
        leftMax[j] = max(leftMax[j - 1], A[j -1]);//由j-1推到j
    }

    rightMin[n - 1] = INF;//A[n-1]右边没有比它更大的数
    for (int k = n-2; k >= 0; --k) {
        rightMin[k] = min(rightMin[k + 1], A[k + 1]);//由k+1推到k
    }

    int num = 0;
    for (int l = 0; l < n; ++l) {
        if(A[l] > leftMax[l] && A[l] < rightMin[l]){//左边所有数比它小,右边所有数比它大
            ans[num++] = A[l];                      //记录主元
        }
    }
    printf("%d\n", num);                            //输出元素个数

    for (int m = 0; m < num; ++m) {
        if(m) printf(" ");
        printf("%d", ans[m]);                      //依次输出所有元素个数
    }
    printf("\n");                                   //没有的时候,输出换行
    return 0;   
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值