HDU1358 Period(KMP)

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4


题目大意:

给一个字符串,从第二个字符开始,让你判断前面字符串是否具有周期性,然后输出此位置和最大周期数。(周期要大于一)

      对 KMP 算法的扩展应用。

从第 i 个字符开始 if(i%(i-next[i])==0),则前面字符串会有重复,其重复次数是 i /(i-next[i]) 。

这个公式不必死记,k=next[i] 表示i前面k-1个字符与总的字符串前k个字符相同 ,注意这里 不是k,因为构建next数组时要加一。

举个例子:abcabcabc 的下一位是9号位,next[9]=6,9-6=3(k表示abc),此时i=9,k=3。

       

#include<iostream>
#include<cstring>
#include<stdio.h>

using namespace std;

char str[1000005];
int Next[1000005];
int n;

void init()
{
    int i=0,j=-1;
    Next[0]=-1;
    while(i<n)
    {
        if(j<0||str[i]==str[j])
          Next[++i]=++j;
        else
            j=Next[j];
    }
}


int main()
{
    int TIME=0;
    while(cin>>n&&n)
    {
        cin>>str;
        init();
        cout<<"Test case #"<<++TIME<<endl;
        for(int i=2;i<=n;++i)
        {
            int k=i-(Next[i]);
            if(k!=i&&(i)%k==0)
            {
                cout<<i<<" "<<i/k<<endl;
            }
        }
        cout<<endl;
    }
}



扩展一点:

这里构造next数组有两种方式:

一种是清华大学老师讲的:如我上面介绍的方法。

另一种是北大老师介绍的:

        

void get_next()
{
	int i=1,j=0;
	next[1]=0;
	while(i<=d)
	{
		if(j==0||a[i]==a[j]) {i++;j++;next[i]=j;}
		else j=next[j];
	}
}
这里记录数据起点不同,这位北大老师从数组坐标1开始储存数据。

本质是一样的。

部分引用:点击打开链接

#include<stdio.h>
#include<string.h>
int next[1000002],d;
char a[1000002];
void get_next()
{
	int i=1,j=0;
	next[1]=0;
	while(i<=d)
	{
		if(j==0||a[i]==a[j]) {i++;j++;next[i]=j;}
		else j=next[j];
	}
}
int main()
{
	int i,k,t=0,flag;
	while(1)
	{
		flag=1;
		memset(next,0,sizeof(next));
		scanf("%d",&d);
		if(d==0) return 0;
		scanf("%s",a+1);
		get_next();
		printf("Test case #%d\n",++t);
		// for(i=1;i<=d+1;i++)  printf("%d ",next[i]);
		// printf("\n");
		for(i=2;i<=d;i++)
		{
			k=i-(next[i+1]-1);<span style="white-space:pre">	</span>//相当于k=(i+1)-next[i+1];本质上与上一题一致
			/*next[i+1]-1是i+1之前的循环长度      用i一减就是剩下的长度 如果剩下的长度为一个重复串的长度
			则可以输出  否则不能输出 如 abcabcabc  next[10]-1=6 用i一减(等于从abcabcabc中把abcabcabc拿走) 
			剩下个3(即abc)  i是3的整数倍(长串的1到i的子串中是全由abc组成) 此时能输出
			next[9]-1=2 说明剩下的不够一个重复串 即不能被i整除  不能输出*/
			if(i!=k&&i%k==0)  printf("%d %d\n",i,i/k);//i==k是指循环长度为0 即没有循环
		}
		printf("\n");
	}
	return 0;
}
/*非优化的next数组的含义是:next[i]=k模式串下标为i的字符的前k-1个字符与开首的前k-1个字符相等
例如 aabaabaab   next[10]=7 表示下标为10之前的字符前6个字符 与开首的前6个字符相等 所以当匹配不成功时 不用回溯到下标为6的位置去继续匹配
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值