poj 1258 Agri-Net

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 57287 Accepted: 23767

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

这道题要求先给出农场的数目,然后就是一个4*4的矩阵,代表着第i个村庄距j村庄的距离。

解题:i到i个村庄之间距离不存在,赋值成最大的数。

用Prim和Kruskal算法解决

Prim算法

import java.util.Queue;
import java.util.Scanner;
import java.util.concurrent.LinkedBlockingQueue;
import java.util.concurrent.PriorityBlockingQueue;

public class Main {
	Queue<Edge> pq;
	Queue<Edge> mst;
	boolean marked[];
	public static void main(String args[]){
		
		
		Main test=new Main();
		while(scan.hasNext()){
			test.start();
		}
		
	}
	static Scanner scan=new Scanner(System.in);
	public void start(){
		
		
		
		int a=scan.nextInt();
		Graph g=new Graph(a);
		marked=new boolean[a];
		for(int i=0;i<a;i++){
			
			for(int j=0;j<a;j++){
				
				g.addEdge(new Edge(scan.nextInt(),i,j));
				
			}
			
		}
		pq=new PriorityBlockingQueue<Edge>();
		mst=new LinkedBlockingQueue<Edge>();
		visit(g,0);
		while(!pq.isEmpty()){
			
			Edge e=pq.poll();
			
			if(marked[e.w]&&marked[e.v]) continue;
		
		
			
			mst.offer(e);
			if(!marked[e.v]) visit(g,e.v);
			if(!marked[e.w]) visit(g,e.w);
			
		}
		
		int sum=0;
		
		for(Edge i:mst){
			
			sum+=i.weight;
			
		}
		System.out.println(sum);
	}
	public void visit(Graph g,int v){
		
		marked[v]=true;
		for(int i=0;i<g.array[v].length;i++){
			if(v!=i){
				
				if(!marked[i]) pq.offer(g.array[v][i]);
				
			}
		}
		
	}
}
class Graph{
	
	Edge array[][];
	int vSize;
	int edgeSize;
	public Graph(int vSize) {
		
		this.array =new Edge[vSize][vSize];
		this.vSize = vSize;
		
		
	}
	public void addEdge(Edge e){
		
		array[e.v][e.w]=e;
		edgeSize++;
	}
	
}
class Edge implements Comparable<Edge>{

	int weight;
	int v;
	int w;
	
	
	public Edge(int weight, int v, int w) {
		super();
		this.weight = weight;
		this.v = v;
		this.w = w;
	}


	public int compareTo(Edge arg0) {
		if(weight>arg0.weight){
			
			return 1;
			
		}else{
			if(weight==arg0.weight){
				return 0;
			}
			return -1;
		}
	
	}
	public int other(int point){
		
		if(v==point) return v;
		else return w;
		
	}


	@Override
	public String toString() {
		return v+" "+w+"\n";
	}
	
	
	
}

Kruskal算法

  • import java.util.Queue;
    import java.util.Scanner;
    import java.util.concurrent.PriorityBlockingQueue;
    
    public class Main {
    
    	int id[];
    	int size[];
    	public int find(int i){
    		
    		if(id[i]!=i) i=find(id[i]);
    		return i;
    		
    	}
    	
    	public void union(int i,int j){
    		
    		int a=find(i);
    		int b=find(j);
    		if(a==b) return;
    		if(size[a]>size[b]) {
    			id[b]=id[a];
    			size[a]+=size[b];
    		}else{
    			id[a]=id[b];
    			size[b]+=size[a];
    			
    			
    		}
    		
    	}
    	public boolean connect(int i,int j){
    		
    		return find(i)==find(j);
    		
    	}
    	
    	public static void main(String args[]){
    		
    		
    		Main main=new Main();
    		while(scan.hasNext()){
    			main.start();
    		}
    		
    	}
    	static Scanner scan=new Scanner(System.in);
    	public void start(){
    		
    		
    		int a=scan.nextInt();
    		id=new int[a];
    		size=new int[a];
    		Queue<Edge> pq=new PriorityBlockingQueue<Edge>();
    		for(int i=0;i<a;i++){
    			
    			for(int j=0;j<a;j++){
    				int d=scan.nextInt();
    				if(i==j){
    					d=Integer.MAX_VALUE;
    				}
    				pq.offer(new Edge(d,i,j));
    				
    			}
    			
    		}
    		for(int i=0;i<id.length;i++){
    			
    			id[i]=i;
    			size[i]=1;
    			
    		}
    		int sum=0;
    		while(!pq.isEmpty()){
    			
    			Edge e=pq.poll();
    			if(connect(e.v,e.w)) continue;
    			union(e.v,e.w);
    			sum+=e.weight;
    			
    			
    			
    		}
    		System.out.println(sum);
    	}
    	class Edge implements Comparable<Edge>{
    
    		int weight;
    		int v;
    		int w;
    		
    		public Edge(int weight, int v, int w) {
    			super();
    			this.weight = weight;
    			this.v = v;
    			this.w = w;
    		}
    
    		public int compareTo(Edge o) {
    			if(weight>o.weight){
    				
    				return 1;
    				
    			}
    			else{
    				if(weight==o.weight){
    					return 0;
    				}
    				return -1;
    			}
    			
    		}
    		
    		
    		
    		
    		
    	}
    }
    

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值