生成树专题----B - Qin Shi Huang's National Road 次小生成树

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself “Qin Shi Huang” because “Shi Huang” means “the first emperor” in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people’s life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
Sample Input
2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40
Sample Output
65.00
70.00

次小生成树的思想做这题;
我们可以先建一棵最小生成树,然后再从这n个城市中选择2个城市,把二者之间的路看做用法术造的路。如果这条路在最小生成树上,即去掉这条边后最小生成树会变成两棵独立的树,那么A/B就是(二者城市的人口数总和/最小生成树的值减去二者之间的长度);如果这条路不在生成树上,那么为了使A/B最大,我们要在最小生成树上删除一条权值最大的边使得生成树分为两棵树,同时这2个城市不在同一颗树上,然后就可以把这两个城市之间的路视为用法术造出的路,A/B就是
(二者城市的人口数总和/最小生成树的值减去二者之间某条使二者连通的边的最大长度)。
综上:我们可以使用used[i][j]表示i与j之间的边是否在最小生成树上,MAX[i][j]表示i到j之间的使得i与j连通的权值最大的边的权值。在prim内更新MAX数组

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_pair
#define pb push_back
#define fi first
#define se second
const int MAXN = 1005;

double lowcost[MAXN];
double mk[MAXN][MAXN];
bool vis[MAXN];
int pre[MAXN];
bool use[MAXN][MAXN];
double MAX[MAXN][MAXN];
int peo[MAXN];
pair<int,int>ptr[MAXN];
int n,t;

double prim()
{
    memset(vis,false,sizeof(vis));
    memset(MAX,0,sizeof(MAX));
    memset(use,false,sizeof(use));
    for(int i = 1;i <= n;++i){
        lowcost[i] = mk[1][i];
        pre[i] = 1;
    }
    lowcost[1] = 0;
    vis[1] = true;
    pre[1] = -1;
    double ans = 0;
    for(int i = 0;i < n - 1;++i){
        double MIN = inf;
        int k = 0;
        for(int j = 1;j <= n;++j){
            if(!vis[j] && lowcost[j] < MIN){
                MIN = lowcost[j];
                k = j;
            }
        }
        if(k == 0)
            break;
        vis[k] = true;
        ans += MIN;
        use[k][pre[k]] = use[pre[k]][k] = true;
        for(int j = 1;j <= n;++j){
            if(vis[j] && j != k) MAX[j][k] = MAX[k][j] = max(MAX[j][pre[k]],MIN);
            if(!vis[j] && lowcost[j] > mk[k][j]){
                lowcost[j] = mk[k][j];
                pre[j] = k;
            }
        }
    }
    return ans;
}

double caldist(pair<int,int>a,pair<int,int>b)
{
    return sqrt(1.0 * (a.fi - b.fi) * (a.fi - b.fi) + 1.0 * (a.se - b.se) * (a.se - b.se));
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i = 1;i <= n;++i){
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            ptr[i].fi = a;ptr[i].se = b;
            peo[i] = c;
        }
        for(int i = 1;i <= n;++i){
            for(int j = i + 1;j <= n;++j){
                mk[i][j] = mk[j][i] = caldist(ptr[i],ptr[j]);
            }
        }
        double ans = prim();
        double tmp = -1;
        for(int i = 1;i <= n;++i){
            for(int j = i + 1;j <= n;++j){
                if(use[i][j]){
                    tmp = max(tmp,(peo[i] + peo[j] + 0.0) / (ans - mk[i][j]));
                    //cout << ans << " " << mk[i][j] << endl;
                }else{
                    tmp = max(tmp,(peo[i] + peo[j] + 0.0) / (ans - MAX[i][j]));
                    //cout << ans << " " << MAX[i][j] << endl;
                }
            }
        }
        printf("%.2lf\n",tmp);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值