uva 1494 - Qin Shi Huang's National Road System(次小生成树类似问题)

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China -- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty -- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor " in Chinese.

\epsfbox{p5713.eps}

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:

There were n cities in China and Qin Shi Huang wanted them all be connected by n - 1 roads, in order that he could go to every city from the capital city Xianyang. Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible -- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.

Would you help Qin Shi Huang?

A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input

The first line contains an integer t meaning that there are t test cases (t$ \le$10).

For each test case:

The first line is an integer n meaning that there are n cities (2 < n$ \le$1000).

Then n lines follow. Each line contains three integers X, Y and P (0$ \le$X, Y$ \le$1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.

It is guaranteed that each city has a distinct location.

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

Sample Output

65.00
70.00

法术只能修一条路,枚举它两端的城市u,v

#include<cstdio>
#include<cmath>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;

const int maxn = 1000 + 10;

struct Edge {
  int x, y;
  double d;
  bool operator < (const Edge& rhs) const {
    return d < rhs.d;
  }
};

struct MST{
    int n, m;//点数和边数
    Edge e[maxn*maxn];//储存所有的边
    int pa[maxn];//用于并查集,父指针
    vector<int> G[maxn];//用于Dfs,储存生成树中每个点相邻的点
    vector<double> C[maxn];//用于Dfs,储存相应的边的权
    vector<int> nodes;//用于Dfs,储存已经遍历过的节点
    double maxcost[maxn][maxn];//储存最小生成树中,u、v唯一路径上的最大权值

    //这里是把无根树,转为了有根树,具体做法:
    //在初始调用时Dfs(0,-1,0),然后后面节点拓展儿子时,不允许向回走
    void dfs(int u, int fa, double facost){
        //先对当前点同所有已访问过的节点,进行更新
        for(int i = 0; i < nodes.size(); i++) {
            int x = nodes[i];
            maxcost[u][x] = maxcost[x][u] = max(maxcost[x][fa], facost);
        }
        nodes.push_back(u);
        //再递归下一个点
        for(int i = 0; i < G[u].size(); i++) {
            int v = G[u][i];
            if(v != fa) dfs(v, u, C[u][i]);
        }
    }

    void init(int n){
        this -> n = n;
        m = 0;
        memset(maxcost,0,sizeof(maxcost));
        nodes.clear();
        for(int i = 0; i < n; i++) { pa[i] = i; G[i].clear(); C[i].clear(); }
    }

    void AddEdge(int x,int y,double dist){
        e[m++] = (Edge){x,y,dist};
    }

    int findset(int x) { return pa[x] != x ? pa[x] = findset(pa[x]) : x; }

    double solve() {
        sort(e, e+m);
        int cnt = 0;
        double ans = 0;
        for(int i = 0; i < m; i++) {
            int x = e[i].x, y = e[i].y, u = findset(x), v = findset(y);
            double d = e[i].d;
                if(u != v) {
                    pa[u] = v;
                    G[x].push_back(y); C[x].push_back(d);
                    G[y].push_back(x); C[y].push_back(d);
                    ans += d;
                    if(++cnt == n-1) break;
                }
            }
        return ans;
    }
};

MST solver;

int px[maxn],py[maxn],pp[maxn];

double Dist(int ax,int ay,int bx,int by){
    return sqrt((ax-bx)*(ax-bx)+(ay-by)*(ay-by));
}

int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        solver.init(n);
        for(int i = 0;i < n;i++)
            scanf("%d%d%d",&px[i],&py[i],&pp[i]);
        for(int i = 0;i < n;i++)
            for(int j = i+1;j < n;j++)
                solver.AddEdge(i,j,Dist(px[i],py[i],px[j],py[j]));
        double total = solver.solve();
        solver.dfs(0,-1,0);
        double ans = -1;
        for(int i = 0;i < n;i++)
            for(int j = i+1;j < n;j++){
                ans = max(ans,(pp[i]+pp[j]) / (total-solver.maxcost[i][j]) );
            }
        printf("%.2lf\n",ans);
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值