【PAT甲级A1001 】A+B Format (20分)(c++)

1001 A+B Format (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10 ^6≤a,b≤10 ^6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题意:

输入两个数,将两数之和表示为标准模式,即每个千位加个逗号。

思路:

需要将数字转换成字符串,应用到stl中to_string函数,正负加以区分,避免出现-,999这样的输出。

参考代码:

#include <iostream>
#include <string>
using namespace std;
int main() {
    int a,b;
    cin>>a>>b;
    string str=to_string(a+b);
    int len=str.length();
    if(str[0]=='-'){
        for(int pos=len-3;pos>1;pos-=3){
            str.insert(pos,",");
        }
    }
    else{
        for(int pos=len-3;pos>0;pos-=3){
            str.insert(pos,",");
        }
    }
    cout<<str<<endl;
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值