【笨方法学PAT】1008 Elevator(20 分)

一、题目

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

二、题目大意

电梯上下,停留5s、上升每层6s、下降每层4s,从0楼开始计算,每次不需要回到0楼。

三、考点

模拟

四、解题思路

1、读入数据;

2、相邻的两层进行处理,如果上升按照上升的时间计算、下降按照下降的时间计算。vec[0] 作为0楼,可以按照0楼开始。

PS. 当然,也可以联机算法,在读取数据的过程中直接进行处理,但我自己觉得,分开处理的话,思考的时间更多,出错的可能性会降低。

五、代码

#include<iostream>
#include<vector>
using namespace std;
int main() {
	int n;
	//读取数据
	cin >> n;
	vector<int> vec(n+1);
	vec[0] = 0;
	for (int i = 1; i <= n; ++i)
		cin >> vec[i];

	//处理数据
	int sum = 0;
	for (int i = 1; i <= n; ++i) {
		//停留时间
		sum += 5;

		//下降时间
		if (vec[i] - vec[i - 1] >= 0)
			sum += (vec[i] - vec[i - 1]) * 6;

		//上升时间
		else
			sum+= (vec[i-1] - vec[i]) * 4;
	}

	//输出结果
	cout << sum << endl;
	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值