PAT | A 1001 Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10^​6
​​ ≤a,b≤10^6 . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

通过代码

#include <iostream>
#include <cmath>
#include <cstring>

int main() {
	int a,b,sum,f=1;
	int num[5],ct=0;
	while(scanf("%d%d",&a,&b)!=EOF){
		ct = 0;
		memset(num,0,5);
		f=1;
		sum = a + b;
		if(sum < 0){
			printf("-");
		}
		sum = abs(sum);
		do{
			num[ct++] = sum % 1000;
			sum = sum / 1000;
		}while(sum != 0);
		printf("%d",num[ct-1]);
		if(ct-1 != 0){
			printf(",");
		}
		for(int i=ct-2; i>=0; i--){
			printf("%03d",num[i]);
			if(i != 0)
				printf(",");
		}
		printf("\n");
			
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值