Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10^6
≤a,b≤10^6 . The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
通过代码
#include <iostream>
#include <cmath>
#include <cstring>
int main() {
int a,b,sum,f=1;
int num[5],ct=0;
while(scanf("%d%d",&a,&b)!=EOF){
ct = 0;
memset(num,0,5);
f=1;
sum = a + b;
if(sum < 0){
printf("-");
}
sum = abs(sum);
do{
num[ct++] = sum % 1000;
sum = sum / 1000;
}while(sum != 0);
printf("%d",num[ct-1]);
if(ct-1 != 0){
printf(",");
}
for(int i=ct-2; i>=0; i--){
printf("%03d",num[i]);
if(i != 0)
printf(",");
}
printf("\n");
}
return 0;
}