PAT A+B Format 1001

题目

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​ ≤a,b≤10​6​​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991


思路

  • 先处理3位一个逗号:
    把a和b的sum按位分解开,放进char栈里,并且如果没遇到最后一个数字就入栈3个就放入一个逗号。
  • 后处理正负号和0:
    如果是负数则输入‘-’,正数不显示符号位,0直接输出程序结束

Code

#include<stdio.h>
#include<math.h>
main()
{
    int a,b,sum,asum,top;
    int flag=0;
    char stack[1000000];
    scanf("%d %d",&a,&b);
    sum=a+b;
    asum=abs(sum);
    top=0;
    while(asum>0)
    {
    	stack[top++]=asum%10+'0';
    	asum/=10;
    	flag++;
    	if(flag==3)
    	{
    		flag=0;
    		if(asum>0)
    			stack[top++]=',';
		}
	}
	if(sum<0)
		stack[top]='-';
	else if(sum>0)
		top--;
	else
		{
			printf("0");
			return 0;
		}
	while(top>=0)
		printf("%c",stack[top--]);

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值