(紫书第三章习题3-10) UVA - 1587 BOX

题目链接:https://vjudge.net/problem/51982/origin

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box.
Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake. Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.


Input
Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet and contains two integer numbers w and h (1 ≤ w,h ≤ 10000) — width and height of the pallet in millimeters respectively.


Output
For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it is possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not possible to do so.


Sample Input
1345 2584 2584 683 2584 1345 683 1345 683 1345 2584 683 1234 4567 1234 4567 4567 4321 4322 4567 4321 1234 4321 1234


Sample Output
POSSIBLE IMPOSSIBLE

题意:

     判断六个面是否能组成一个长方形。

思路:

    ......结构体排序,保证最大的四个边,中等的四个边,最小的四个边都一直且只能出现在一块区域,之后比较。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;

struct Q
{
    int x,y;
}q[6];

bool cmp( Q a,Q b )
{
    if( a.x > b.x  )
    return true;
    else if( a.x==b.x && a.y > b.y )
    return true;
    else return false;
}

int main()
{
    int x,y;
    //freopen("in.txt","r",stdin);
    while( cin >> q[0].x >> q[0].y >> q[1].x >> q[1].y >> q[2].x
          >> q[2].y >> q[3].x >> q[3].y >> q[4].x >> q[4].y >> q[5].x >> q[5].y )
    {
        for( int i=0; i<6; i++ )
        {
            if( q[i].x < q[i].y )
            swap(q[i].x,q[i].y);
        }
        sort(q,q+6,cmp);
        /*for( int i=0; i<6; i++ )
        {
            printf("len:%d  wid:%d\n",q[i].x,q[i].y);
        }*/
        if( q[0].x==q[1].x && q[1].x==q[2].x && q[2].x==q[3].x
            && q[4].x == q[5].x && q[5].x == q[0].y && q[0].y ==q[1].y
            && q[2].y == q[3].y && q[3].y == q[4].y && q[4].y ==q[5].y )
            printf("POSSIBLE\n");
        else
            printf("IMPOSSIBLE\n");
    }
    return 0;
}
//日常水题,感觉输入有点坑
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值