POJ3984—迷宫问题(bfs+ 打印路径)

定义一个二维数组: 

int maze[5][5] = {

    0, 1, 0, 0, 0,

    0, 1, 0, 1, 0,

    0, 0, 0, 0, 0,

    0, 1, 1, 1, 0,

    0, 0, 0, 1, 0,

};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
 

#include<iostream>
#include<queue>
using namespace std;
const int MAX = 10;
int n=5, graph[MAX][MAX];
struct Position {
	int x = 0, y = 0;
	Position operator+(pair<int, int>& dir) {
		return { x + dir.first,y + dir.second };
	}
};
pair<int, int> dir[4] = { {1,0},{0,1},{0,-1},{-1,0} };		//顺序不能乱,因为0和4-1,1和4-2,方向相反,输出时需要回溯
void print(Position pos) {
	if (pos.x || pos.y)										//回溯打印
		print(pos + dir[4 + graph[pos.x][pos.y]]);
	cout << "(" << pos.x << "," << pos.y << ")" << endl;
}
void bfs() {
	Position start;
	queue<Position> que;
	que.push(start);
	while (!que.empty()) {
		for (int i = 0; i < 4; i++) {
			Position pos = que.front() + dir[i];
			if (pos.x >= 0 && pos.x < n && pos.y >= 0 && pos.y < n && !graph[pos.x][pos.y]) {
				que.push(pos);
				graph[pos.x][pos.y] -= (i + 1);
				if (pos.x == n - 1 && pos.y == n - 1)
					return;
			}
		}
		que.pop();
	}
}

int main() {
	for (int i = 0; i < n; i++)
		for (int j = 0; j < n; j++)
			scanf("%d", &graph[i][j]);
	bfs();
	print({ n - 1,n - 1 });
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值