PAT 甲级 1013 Battle Over Cities (25分)

题目

1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting c i t y 1 city_1 city1- c i t y ​ 2 city_​2 city2 and c i t y ​ 1 city_​1 city1​​ - c i t y 3 city_3 city3​ . Then if c i t y 1 city_1 city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway c i t y 2 city_2 city2 - c i t y ​ 3 city_​3 city3 .

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K K K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0

题目大意

给出N个城市,M条道路,每条路连通两个城市,然后给出K个沦陷的城市,对其中每个沦陷的城市,求出当它沦陷的时候,为了使剩余的城市连通,最少需要多少条路。

思路

对应无向图求连通分量个数问题,n个连通分量则需要n-1条路,借助DFS来求连通分量个数。

代码

#include<bits/stdc++.h>
using namespace std;
int N, M, K, ans;
vector<int> edge[1010];
bool visit[1010] = {false};
void dfs(int st){
    visit[st] = true;
    for(int i=0; i<edge[st].size(); i++){
        if(!visit[edge[st][i]])
            dfs(edge[st][i]);
    }
}
int main(int argc, const char * argv[]) {
    int c1, c2;
    cin>>N>>M>>K;
    for(int i=0; i<M; i++){
        cin>>c1>>c2;
        edge[c1].push_back(c2);
        edge[c2].push_back(c1);
    }
    for(int i=0; i<K; i++){
        cin>>c1;
        ans = 0;
        fill(visit, visit+N+1, false);
        visit[c1] = true;
        for(int j=1; j<=N; j++){
            if(!visit[j]){
                dfs(j);
                ans++;
            }
        }
        printf("%d\n", ans-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值