PAT 甲级 1029 Median (25分)

题目

1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题目大意

找出两个已经升序排列的数组的中位数,其中偶数序列的中位数,设总共N个元素,中位数是第N/2个元素。

思路

已经知道了各个序列的元素数量,就能知道总共有几个数,可以得知中位数应该是第几个数;
双指针的思想,两个指针分别从每个数组的开头开始,相互比较,谁小往右移;直到到达了中位数所在的地方,即是第med个小的数,或者其中一个数字序列到达尽头,此时可以计算得到中位数在另一个序列的下标;

代码

#include<bits/stdc++.h>
using namespace std;
const int maxN = 200005;
// 找出两个数组的中位数
// 根据题目给的例子可以得知对于偶数个元素的中位数的位置是哪个 (num+1)/2
// 最后一个测试点超时了,将输入输出换成scanf和printf就通过了
int main(int argc, const char * argv[]) {
    int a_size, b_size,a[maxN], b[maxN], res, t=0, i=1, j=1;
    scanf("%d", &a_size);
    for(int i=1; i<=a_size; i++)
        scanf("%d", &a[i]);
    scanf("%d", &b_size);
    for(int i=1; i<=b_size; i++)
        scanf("%d", &b[i]);

    int med = (a_size + b_size + 1) / 2;
    while(i <= a_size && j <= b_size){
        if(a[i] < b[j])
            res = a[i++];
        else
            res = b[j++];
        t++;
        if(t == med) break;
    }
    if(i <= a_size && t < med)
        res = a[i + med - t - 1];
    else if(j <= b_size && t < med)
        res = b[j + med - t - 1];
    printf("%d", res);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值