PAT 甲级 1029 Median (25分)

题目

1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题目大意

找出两个已经升序排列的数组的中位数,其中偶数序列的中位数,设总共N个元素,中位数是第N/2个元素。

思路

已经知道了各个序列的元素数量,就能知道总共有几个数,可以得知中位数应该是第几个数;
双指针的思想,两个指针分别从每个数组的开头开始,相互比较,谁小往右移;直到到达了中位数所在的地方,即是第med个小的数,或者其中一个数字序列到达尽头,此时可以计算得到中位数在另一个序列的下标;

代码

#include<bits/stdc++.h>
using namespace std;
const int maxN = 200005;
// 找出两个数组的中位数
// 根据题目给的例子可以得知对于偶数个元素的中位数的位置是哪个 (num+1)/2
// 最后一个测试点超时了,将输入输出换成scanf和printf就通过了
int main(int argc, const char * argv[]) {
    int a_size, b_size,a[maxN], b[maxN], res, t=0, i=1, j=1;
    scanf("%d", &a_size);
    for(int i=1; i<=a_size; i++)
        scanf("%d", &a[i]);
    scanf("%d", &b_size);
    for(int i=1; i<=b_size; i++)
        scanf("%d", &b[i]);

    int med = (a_size + b_size + 1) / 2;
    while(i <= a_size && j <= b_size){
        if(a[i] < b[j])
            res = a[i++];
        else
            res = b[j++];
        t++;
        if(t == med) break;
    }
    if(i <= a_size && t < med)
        res = a[i + med - t - 1];
    else if(j <= b_size && t < med)
        res = b[j + med - t - 1];
    printf("%d", res);
    return 0;
}
### 关于PTA甲级1029题目的解析 #### 题目描述 PTA甲级1029题目名为 **"Median"**,其主要目标是计算一组数的中位数。具体来说,给定一系列整数,要求按照从小到大的顺序排列这些整数,并返回其中位数。 - 如果序列长度为奇数,则中位数为中间位置的那个数; - 如果序列长度为偶数,则中位数为中间两个数的平均值。 以下是更详细的输入输出说明: #### 输入规格 输入的第一行为一个正整数 \(N\) (\(1 \leq N \leq 10^5\)),表示后续待处理的数据数量。 第二行为 \(N\) 个由空格隔的整数,范围在 \([-10^6, 10^6]\) 内。 #### 输出规格 输出一行,包含一个浮点数,保留一位小数,表示该组数据的中位数。 --- #### 解决方案 为了高效求解此问题,可以采用以下方法: 1. 使用 C++ 的 `std::vector` 或 Python 的列表来存储输入数据。 2. 对数组进行排序操作,时间复杂度为 \(O(N \log N)\),这是必要的步骤以便找到中位数的位置。 3. 判断数组长度的奇偶性: - 若为奇数,直接取中间索引对应的数值作为中位数。 - 若为偶数,取中间两个数的均值作为中位数。 下面是基于上述逻辑实现的具体代码示例: ```cpp #include <iostream> #include <algorithm> #include <vector> using namespace std; int main() { int N; cin >> N; vector<int> nums(N); for (int i = 0; i < N; ++i) { cin >> nums[i]; } sort(nums.begin(), nums.end()); double median; if (N % 2 == 1) { // 奇数情况 median = static_cast<double>(nums[N / 2]); } else { // 偶数情况 median = (static_cast<double>(nums[(N / 2) - 1]) + static_cast<double>(nums[N / 2])) / 2.0; } printf("%.1f\n", median); // 控制输出精度至小数点后一位 return 0; } ``` 对于 Python 实现版本,也可以非常简洁地完成相同功能: ```python import sys def find_median(): input_data = sys.stdin.read() lines = input_data.splitlines() n = int(lines[0]) numbers = list(map(int, lines[1].split())) numbers.sort() if n % 2 == 1: median = float(numbers[n // 2]) else: mid1 = numbers[n // 2 - 1] mid2 = numbers[n // 2] median = (mid1 + mid2) / 2 print(f"{median:.1f}") find_median() ``` 以上两种语言的解决方案都能满足题目需求,并且具有较高的效率[^1]。 --- #### 测试案例 假设输入如下: ``` 5 1 3 5 2 4 ``` 经过排序后的序列为 `[1, 2, 3, 4, 5]`,因此中位数为第 3 个元素即 `3.0`。 如果输入改为: ``` 6 1 3 5 2 4 6 ``` 则排序后得到 `[1, 2, 3, 4, 5, 6]`,此时中位数为 `(3 + 4) / 2 = 3.5`。 --- #### 性能优化提示 尽管标准算法已经足够快速,但在极端情况下(如接近最大输入规模),仍需注意内存配和 I/O 效率。例如,在 C++ 中可以通过提前预留向量大小减少动态扩展开销;而在 Python 中可考虑使用更快的文件读写方式替代默认的标准输入流[^2]。 ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值