PAT 甲级 1047 Student List for Course (25分)

题目

1047 Student List for Course (25分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题目大意

给出N个学生、课程数量K;
接下来N行,每行输入为学生姓名和所选的课程;
要求给定课程号,输出该课程所有学生姓名,按字母序升序

思路

用vector<vector>就可以了,没用散列也没超时;

代码

#include<bits/stdc++.h>
using namespace std;
int main(int argc, const char * argv[]) {
    int N, K, C, a;
    string name;
    vector<vector<string>> course2stu;
    cin>>N>>K;
    course2stu.resize(K+1);
    for(int i=0; i<N; i++){
        cin>>name>>C;
        for(int j=0; j<C; j++){
            cin>>a;
            course2stu[a].push_back(name);
        }
    }
    for(int i=1; i<=K; i++){
        printf("%d %d\n", i, course2stu[i].size());
        sort(course2stu[i].begin(), course2stu[i].end(), [](const string& a, const string& b){
            return a < b;
        });
        for(auto it : course2stu[i])
            printf("%s\n", it.c_str());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值