【通过PAT复习C++与数据结构】PAT-A 1051 Pop Sequence (25 分)

题目

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

大意

给定一个大小的栈,判断出栈序列是否有效

直觉

直接模拟进栈出栈过程,如果过程中出现了违法行为,输出no,否则yes。
进栈出栈过程中需要判定哪些行为是违法的呢:

  1. 栈溢出
  2. 先出了不是顶端元素的元素

代码

#include<iostream>
#include<stack>
using namespace std;
int main(){
	int M,N,K;
	cin>>M>>N>>K;
	stack<int> st;
	int input[N];
	int p;
	for(int i=0;i<K;++i){
		for(int j=0;j<N;++j)cin>>input[j];
		p=0;
		while(!st.empty()) st.pop();
		for(int j=1;j<=N;++j){
			st.push(j);
			if(st.size()>M)break;
			while(st.size() !=0&&st.top()==input[p]){
				st.pop();
				++p;
			}
		}
		if(p==N)cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	} 
	return 0;
}

提交时间 状态 分数 题目 编译器 耗时 用户
2019/8/16 10:10:28
答案正确
25 1051 C++ (g++) 4 ms Chester
测试点 结果 耗时 内存
0 答案正确 3 ms 372 KB
1 答案正确 3 ms 368 KB
2 答案正确 3 ms 384 KB
3 答案正确 4 ms 424 KB
4 答案正确 3 ms 424 KB
5 答案正确 3 ms 356 KB

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值