1015. Reversible Primes (20)

原题链接
这里写链接内容
题目
1015. Reversible Primes (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
思路
一开始没看懂题目,还是英语不过关。
其实很简单,先判断一下n是否为质数,再把n转换成D进制下的数,再reverse,再转换成十进制判断是否为质数。
代码

#include<iostream>
#include<math.h>
using namespace std;
int change(int n, int D)
{

    int cha=0;
    while (n)
    {
        cha = cha *D + n%D;
        n /= D;
    }
    return cha;
}
bool is_prime(int n)
{
    if (n <= 1)
        return false;
    if (n == 2 || n == 3)
        return true;
    for (int i = 2; i <= sqrt(n); i++)
    {
        if (n%i == 0)
            return false;
    }
    return true;
}
int main()
{
    int n;
    while (cin >> n)
    {
        if (n < 0)
            break;

        int d;
        cin >> d;
        if (is_prime(n)&&is_prime(change(n, d)))
            cout << "Yes" << endl;
        else
            cout << "No" << endl;
    }
    return 0;
}

结果
这里写图片描述
注意
第四个测试用例是判断质数函数中,sqrt(n)是<=,=号不能忘记!
还有change函数不用再创建数组,省点空间。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值