A-(博弈)

A - A
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u
use MathJax to parse formulas

Description

After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.

The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.
 

Input

The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=10 9,1<=K<=10).
 

Output

For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
 

Sample Input

 
    
23 13 2
 

Sample Output

 
    
Case 1: firstCase 2: second

思路:如果每次只能拿一个,看总个数,奇数则A赢,偶数B赢
如果每次能拿两个以上,且总数大于k,那么后手一定赢,因为后手每次都拿和先手对着的

其他的情况都是先手赢

代码:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int t,k,n,d=1,flag;
    scanf("%d",&t);
    while(t--)
    {
        flag=1;
        scanf("%d%d",&n,&k);
        if(k==1)
          if(n%2==0)
            flag=2;
        if(n>k&&k!=1)
          flag=2;
        if(flag==1)
          printf("Case %d: first\n",d);
        else
            printf("Case %d: second\n",d);
        d++;


    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值