hdu_oj3951Coin Game(对称博弈)

Problem Description

After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.


The game goes like this: 
Two players start the game with a circle of n coins. 
They take coins from the circle in turn and every time they could take 1~K continuous coins. 
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game. 
Suppose that those two players always take the best moves and never make mistakes. 
Your job is to find out who will definitely win the game.

Input

The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=109,1<=K<=10).

Output

For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)

Sample Input

2

3 1

3 2

Sample Output

Case 1: first

Case 2: second

刚看这道题目的时候以为是巴什博弈模板,想都没想直接就码了,直接wa,然后重新看题才知道并不是那么回事,这次我们需要用到对称的思想

我们发现如果k=1,那么我们只需要判断n是奇数还是偶数就可以了,如果n是奇数那么先手必胜,如果n是偶数,先手必败

如果k不等于1,如果k>n那么先手可以一次拿走所有的硬币,先手必胜,反之这时候先手拿完就会断环,那么聪明的后手就可以创造出一种对称的局面,形成一条链,后手要么可以全部拿走,要么先手拿几个后手就在对称的位置拿几个这时候后手必胜

下面附上ac代码

#include <iostream>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <queue>
using namespace std;
typedef long long ll;
int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0),cout.tie(0);
    ll t;
    ll n,k;
    cin>>t;
    for(ll i=1;i<=t;i++)
    {
        cin>>n>>k;
        if(k==1)
            if(n%2==1)
                cout<<"Case "<<i<<": first"<<endl;
            else
                cout<<"Case "<<i<<": second"<<endl;
        else
            if(k>=n)
                cout<<"Case "<<i<<": first"<<endl;
            else
                cout<<"Case "<<i<<": second"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值