LightOJ 1010 Knights in Chessboard(规律)

Knights in Chessboard

Given an m x n chessboard where you want to place chess knights. You have to find the number of maximum knights that can be placed in the chessboard such that no two knights attack each other.

Those who are not familiar with chess knights, note that a chess knight can attack 8 positions in the board as shown in the picture below.

在这里插入图片描述

Input
Input starts with an integer T (≤ 41000), denoting the number of test cases.

Each case contains two integers m, n (1 ≤ m, n ≤ 200). Here m and n corresponds to the number of rows and the number of columns of the board respectively.

Output
For each case, print the case number and maximum number of knights that can be placed in the board considering the above restrictions.

Sample Input

3
8 8
3 7
4 10

Sample Output

Case 1: 32
Case 2: 11
Case 3: 20

题意
给出棋盘大小,找到可以放的最多互不攻击的骑士棋子,其中骑士棋子攻击图在题中

题解
我们设 a n s ans ans为骑士棋子数量, k = m ∗ n k=m*n k=mn为棋盘大小
首先,很明显这棋盘颜色都明摆着告诉我们,当棋盘足够大( m 、 n > = 3 m、n>=3 mn>=3)时, k k k为奇数, a n s = k / 2 + 1 ans=k/2+1 ans=k/2+1 k k k为偶数时, a n s = k / 2 ans=k/2 ans=k/2
其次就是考虑特殊情况,当 n = 1 n=1 n=1时, a n s = m ans=m ans=m,当 m = 1 m=1 m=1时, a n s = n ans=n ans=n
n 、 m n、m nm有一个为2时,我们判断棋盘可以分成多少2x2的小棋盘,我们设可以分为 x = k / 4 x=k/4 x=k/4个(注意后面可能有两个格子空余),如果我们不考虑可能多出来的两个小格子,那么 a n s = ( x / 2 + x % 2 ) ∗ 4 ans=(x/2+x\%2)*4 ans=(x/2+x%2)4,再加上可能存在的两个小格子,当 x % 2 = 0 且 k % 4 = ̸ 0 x\%2=0且k\%4=\not0 x%2=0k%4≠0时, a n s + 2 ans +2 ans+2

代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <math.h>
#include <ctime>
#include <unordered_map>
//#include <tr1/unordered_map>

using namespace std;
#define me(x,y) memset(x,y,sizeof x)
#define MIN(x,y) x < y ? x : y
#define MAX(x,y) x > y ? x : y

typedef long long ll;
typedef unsigned long long ull;

const long double INF = 0x3f3f3f3f;
const int MOD = 1e9+7;
const double eps = 1e-06;
const long double PI = std::acos(-1);
const int M=32768;
const int maxn = 1010;


int main() {
    int t,ca=1;
	cin>>t;
	while(t--){
		int m,n;
		cin>>m>>n;
		int k = m*n;
		int ans;
		if(m == 1) ans = n;
		else if(n == 1) ans= m;
		else if(m == 2||n == 2){
			int x = k/4;
			ans = (x/2+x%2)*4;
			if(x%2 == 0 && k%4 != 0) ans += 2;
		}
		else ans = (k%2==0)?k/2:(k/2+1);
		printf("Case %d: %d\n",ca++,ans);
	}
    return 0;
}

/*

*/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要求出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先筛选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function(数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值