1127 ZigZagging on a Tree (30分)

 

1127 ZigZagging on a Tree (30分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15
#include <iostream>
#include <algorithm>
#include<vector>
#include<map>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<set>
#include<unordered_map>
#include<queue>
#include<climits>
#include<stack>
using namespace std;
const int maxn= 10000+10;
int n,root;
vector<int>result[35],post,in;
struct node{
	int index,depth;	
	
};

int tree[35][2];

void dfs(int& index,int inl,int inr,int pol,int por){
	if(inl > inr) return;
	index=por;
	int i=0;
	while(i<inr&&in[i]!=post[por]) i++;
	dfs(tree[index][0],inl,i-1,pol,pol+i-1-inl);
	dfs(tree[index][1],i+1,inr,pol+i-inl,por-1);	
}

void bfs(){
	queue<node>q;
	q.push(node{root,0});
	while(!q.empty()){
		node temp= q.front();
		q.pop();
		result[temp.depth].push_back(post[temp.index]);
		if(tree[temp.index][0]!=0)
			q.push(node{tree[temp.index][0],temp.depth+1});
		if(tree[temp.index][1]!=0)
			q.push(node{tree[temp.index][1],temp.depth+1});
	
	}
	
	
}

int main(){
	cin>>n;
	in.resize(n+1),post.resize(n+1);
	for(int i=1;i<=n;i++) cin>>in[i];
	for(int i=1;i<=n;i++) cin>>post[i];
	dfs(root,1,n,1,n);
	bfs();
	cout<<result[0][0];
	for(int i=1;i<35;i++){
	
		if(i%2==1){
			for(int j=0;j<result[i].size();j++)	
				cout<<" "<<result[i][j];
		}else{
			for(int j=result[i].size()-1;j>=0;j--)
				cout<<" "<<result[i][j];			
		}		
	}
		


	return 0;	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值