C++/Python PAT乙级1058 选择题 (20分)

批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。

输入格式:
输入在第一行给出两个正整数 N(≤ 1000)和 M(≤ 100),分别是学生人数和多选题的个数。随后 M 行,
每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、
正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。
各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……),
按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

输出格式:
按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。
最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从 1 开始编号)。如果有并列,
则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行
输出 Too simple。

输入样例:
3 4 
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (2 b d) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (2 b c) (4 a b c d)


输出样例:
3
6
5
2 2 3 4

C++

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <stdlib.h>
using namespace std;
struct problem
{
    int a,b,c;//满分值,选项个数,正确选项个数
    char s[5];//所有正确选xiang
};
int main()
{
    int n,m;//学生人数和多选题的个数
    cin >> n >> m;
    problem p[m];
    for(int i=0;i<m;i++)
    {
        cin >> p[i].a >> p[i].b >> p[i].c;
        for(int j=0;j<p[i].c;j++) {cin >> p[i].s[j];}
    }
    int score[n]={0};
    int wrong[m]={0};
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            int x=0;
            char y[5];
            getchar();//不加就错误()()之间有空格
            scanf("(%d",&x);
            for(int t=0;t<x;t++)
                cin >> y[t];
            scanf(")");
            //getchar();
            if(x==p[j].c)
            {
                int flag=0;
                for(int t=0;t<x;t++)
                {
                    if(y[t]!=p[j].s[t])  {flag=1;wrong[j]++;break;}
                }
                if(flag==0) score[i]+=p[j].a;
            }
            else wrong[j]++;
        }
    }
    for(int i=0;i<n;i++)
    {
        cout << score[i] << endl;
    }
    int max_value=*max_element(wrong,wrong+m);
    if(max_value==0) cout <<"Too simple";
    else
    {
        cout << max_value;
        for(int i=0;i<m;i++)
        {
           if(wrong[i]==max_value) {cout <<' '<< i+1;}
        }
    }
    return 0;
}

Python

N,M=map(int,input().split())
lst=[]
for i in range(M):
    l=list(input().split())
    lst.append(l)
wrong=list(0 for i in range(M))
for i in range(N):
    a=list(input())
    count,score=0,0
    for j in range(len(a)):
        if '1'<=a[j]<='5':
            l="".join(a[j:j+int(a[j])*2+1])
            if l==" ".join(lst[count][2:]):
                score+=int(lst[count][0])
            else:
                wrong[count]+=1
            count+=1
    print(score)
m=max(wrong)
if m!=0:
    w=str(m)
    for i in range(M):
        if wrong[i]==m:
            w+=' '+str(i+1)
else:
    w='Too simple'
print(w)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值