What day is that day? ZOJ - 3785

It's Saturday today, what day is it after 1^1 + 2^2+ 3^3 + ... + N^N days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N(1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input

2
1
2

Sample Output

Sunday
Thursday

Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.


题意:今天是周六,输入N,输出 1^1 + 2^2+ 3^3 + ... + N^N 天后是周几。


#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
#include<set>
#include<map>
#include<list>
const int INF = 0x3f3f3f3f;
const int maxn = 20000 + 10;
int c[300];
void x()
{
	int t;
	long long ans = 1, a = 0;
	//找出规律,294为一个周期;
	for (int i = 1; i <= 294; i++)
	{
		ans = 1;
        //在n的n次方的过程中,每次乘n的时候都要模7;
		for (int j = 1; j <= i; j++)
			ans = ans*i%7;
		//从1的1次方加到n的n次方;
		a = a + ans;
		c[i] = a % 7;//把一个周期的存入数组c中;
	}
}
int main()
{
	int t;
	char s[][20]= { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday" };
	long long n;
	scanf("%d", &t);
	x();
	while (t--)
	{
		scanf("%lld", &n);
		int p = n % 294;//计算n为周期中的第几个;
		int q = c[p] + 6;//因为今天时周六;
		printf("%s\n", s[q % 7]);//计算今天是周几;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值