PAT 1006 Sign In and Sign Out (25分)

题目:
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

解题思路:
题目首先输入进入电脑房签到的人数,然后分别输入每个人的ID号,签到的时间和签退的时间,第一个签到的人打开门,最后一个签退的人锁门,最后要求输出第一个签到的人的ID和最后一个签退的人的ID。
因此本题可以将每个人签到的时间和签退的时间转换成整数进行比较,然后找出签到时间的最小值和签退时间的最大值。

代码如下:

#include<stdio.h>
#include<string>
#include<iostream>
#define MAX 10001
using namespace std;

int M;

typedef struct persons{
	string ID;
	string in_time;//签到时间
	string out_time;//签退时间
};

int main() {
	int max = -1,min=1000001;
	int InID, OutID;
	cin >> M;
	struct persons per[MAX];
	for (int i = 0; i < M; i++) {
		cin >> per[i].ID >> per[i].in_time >> per[i].out_time;
	}
	for (int i = 0; i < M; i++) {

		int Intime = ((per[i].in_time[0] - '0') * 10 + per[i].in_time[1] - '0') * 3600 + ((per[i].in_time[3] - '0') * 10 + per[i].in_time[4] - '0') * 60
			+ ((per[i].in_time[6] - '0') * 10 + per[i].in_time[7] - '0');

		int Outtime = ((per[i].out_time[0] - '0') * 10 + per[i].out_time[1] - '0') * 3600 + ((per[i].out_time[3] - '0') * 10 + per[i].out_time[4] - '0') * 60
			+ ((per[i].out_time[6] - '0') * 10 + per[i].out_time[7] - '0');

		if (Intime < min) {
			min = Intime;
			InID = i;
		}
		if (Outtime > max) {
			max = Outtime;
			OutID = i;
		}
	}
	cout << per[InID].ID << " " << per[OutID].ID;

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值