PAT 甲级 1001(A+B Format)

题目要求

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 10^6 106≤a,b≤ 1 0 6 10^6 106. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

翻译

给一个数a和b,返回两数相加的结果,但是需要符合英文的标准,每三位打一个逗号,类似xxx,xxx,xxx

代码

#include <iostream>
using namespace std;
int main() {
    int a, b;
    cin >> a >> b;
    string str = to_string(a + b);
    int len = str.length();
    for (int i = 0; i < len; i++) {
        cout << str[i];
        if (str[i] == '-') continue;
        if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";
    }
    return 0;
}

思路

本来打算等乙级刷完再刷甲级的,没想到啊,甲级的题目比乙级还要多,所以暂时调整甲乙比为1:2,之后将持续更新。
那么看这道题目,我们有两个思路,一个是倒过来看,每三个打一个逗号,但是这样需要重新进行字符串存储,想想挺麻烦的,另一种是正序,每一循环打印一下,遇到要打逗号的时候再打一下,按照这个思路输出很方便。
这里呢,使用第二种思路。
这样的话很自然的会想到正负号的区别,可以使用长度来统一处理

	string str = to_string(a + b);
    int len = str.length();
    for (int i = 0; i < len; i++) {
        cout << str[i];
        if (str[i] == '-') continue;
        if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";
    }

主要就是if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";这一句
我们可以发现一个规律不管是否有负号,都是适用的。
大家可以画一下试试,我就不画图啦。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值