PAT 1005 Spell It Right

该博客介绍了一个程序,其功能是接收一个非负整数N,计算所有数字之和,然后将和的每个数字用英文单词输出。程序通过读取输入,将数字字符串转换为整数,计算总和,再将总和转换回字符串,并逐个输出对应的英文单词。提供了两种不同的实现方式,一种使用了字符串转换,另一种则是柳神的简洁代码。
摘要由CSDN通过智能技术生成

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input

12345

Sample Output

one five
#include <iostream>
using namespace std;
#include <string>
#include <vector>


int main(){
    //因为本题给出 N值 远远超出long long 所以不能用整型定义它 只能用 字符串来代替输入
    //题目大意:给一个非负正数N,计算N的每一位相加的和,然后输出和的每一位的英文读音~

    //分析:1、求出每一位相加的和sum  2、将sum转换为string s  3、将string s的每一位输出对应的英文读音~
    string a;
    cin >> a;
    
    int sum = 0;
     for (int i = 0; i < a.length(); i++) //将每一位转换成 数字 累加到 sum上去
        sum += (a[i] - '0');
    
    vector<int> v;
    
    if(sum == 0){ //如果和 为0 直接输出
        cout << "zero" << endl;
        return 0;
    }
    
    while(sum){ //把和的 每一位放进 v中
        v.push_back(sum % 10);
        sum /= 10;
    }
    
    string s[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    
    for(int i = v.size() - 1; i >= 0; i--){
        int tmp = v[i]; //用tmp保存当前位上的值
        if(i != 0)
            cout << s[tmp] << " ";
        else
            cout << s[tmp] << endl;
    }
      
    return 0;
}

顺带贴柳神的代码,柳神真的tql,写的代码总是那么简洁巧妙!
#include <iostream>
using namespace std;
int main() {
    string a;
    cin >> a;
    int sum = 0;
    for (int i = 0; i < a.length(); i++)
        sum += (a[i] - '0');
    string s = to_string(sum);
    string arr[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    cout << arr[s[0] - '0'];
    for (int i = 1; i < s.length(); i++)
        cout << " " << arr[s[i] - '0'];
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值