hdu 1011 Starship Troopers 树形背包 !!!原因不明wa?★★★☆

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15164    Accepted Submission(s): 4076


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
  
  
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 

Sample Output
  
  
50 7
 

Author
XU, Chuan
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1561  1203  2415  2546  2602 
 
感觉这题真是。。。,不仅题目莫名其妙,而且感觉有点问题,至少有一个坑点:


一个小trick:即使某个山洞的 bug 数量为 0,那么也至少需要 1 个士兵去获取 brain,所以当现在手上的士兵数量为 0 的时候,可以直接输出 0 了(转自 http://www.cnblogs.com/zhj5chengfeng/archive/2013/03/09/2951237.html)


见注释:

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<cctype>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI (4.0*atan(1.0))
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   ind<<1,le,mid
#define rson    ind<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second
#define ysk(x)  (1<<(x))
using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn= 110    ;
const int maxV= 110  ;
int val[maxn];
int cost[maxn];
vector<int> G[maxn];
int dp[maxn][maxV];
int n,V;
void init()
{
    for(int i=1;i<=n;i++)   G[i].clear();
}

void dfs(int x,int fa)//x表示当前结点,fa表示父亲
{
    for(int v=0;v<cost[x];v++)  dp[x][v]=0;
    //cost[x]表示当前攻占结点所需花费,现在考虑对于x为根的子树,解决子问题
    //V背包的最大体积,在这个题目里指的是最大人数。
    //dp[x][v]表示结点x为根节点的子树,当有v个人时,最多能得到的价值
    //对于每个子树,必须先攻打树根
    //所以小于cost[x]最大价值均为0
    for(int v=cost[x];v<=V;v++)  dp[x][v]=val[x];
    //对于体积大于等于cost[x]的背包,至少可以的到val[x]的价值
    /*在此处dp[x][0]=0;必须wa,why?I don't know 。*/
    for(int ii=0;ii<G[x].size();ii++)
    {
        //枚举子结点
        int y=G[x][ii];
        if(y==fa)  continue;//不考虑父节点作为物品进行转移
        dfs(y,x);

        for(int v=V;v>=cost[x];v--)//v是当前结点背包容量,v2是子结点y的容量,当前结点必须有cost[x],否则没有攻打
        {
            for(int v2=max(1,cost[y]);v2<=V;v2++) if(v-v2>=cost[x])//v2必须有cost[y],
            {
                dp[x][v]=max(dp[x][v],dp[x][v-v2]+dp[y][v2]);

            }
        }

    }

/*  dp[x][0]=0;在此处放一个dp[x][0]=0时,就算把 for(int v2=max(1,cost[y]);v2<=V;v2++)
改为 for(int v2=0;v2<=V;v2++) 或者for(int v2=cost[y];v2<=V;v2++)也可以AC

但是如果不放 ,必须有for(int v2=max(1,cost[y]);v2<=V;v2++)

  */

}
int main()
{
    while(~scanf("%d%d",&n,&V)&&(~V||~n))
    {
        init();
        int x,y;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&val[i]);
            cost[i]= x%20==0?x/20:x/20+1  ;
//            cost[i]=max(1, x%20==0?x/20:x/20+1)  ;
        }

        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            G[x].push_back(y);
            G[y].push_back(x);
        }
        if(!V)  {puts("0");continue;}
        dfs(1,-1);
        printf("%d\n",dp[1][V]  );
    }


    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值