HDU-4496-D-City(并查集基础)

D-City

Problem Description

Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input

First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input

5 10 
0 1 
1 2 
1 3 
1 4 
0 2 
2 3 
0 4 
0 3 
3 4 
2 4
 

Sample Output

1 
1 
1 
2 
2 
2 
2 
3 
4 
5
Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. 
The first 3 lines of output are 1s  because  after  deleting  the  first  3  edges  of  the  graph,  all  vertexes  still  connected together. 
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. 
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N. 

解题思路:

题目很好理解,给一个图n个节点m条边。
求删掉前 i 条边时整个图有多少个连通块。
求连通块可以很自然的想到并查集,然后要求删掉前 i 条边时的情况。
可以反过来思考,考虑加入后 i 条时有多少个连通块,然后倒着输出就完事了。

AC代码:

#include <bits/stdc++.h>
#include <utility>
#include <string>
#define int long long
using namespace std;
const int mod = 1e9+7;
const int N = 2e5+10;
int a[N];
int p[N];

struct node{
    int x,y;
}nodes[N];

int _find(int x)
{
    return p[x] == x ? x : p[x] =  _find(p[x]);
}

signed main()
{
    int n,m;
    while(~scanf("%lld%lld",&n,&m))
    {
        for(int i = 0 ; i < m ; i ++)
            scanf("%lld%lld",&nodes[i].x,&nodes[i].y);
        for(int i = 0 ; i < n ; i ++)
            p[i] = i;
        int ans = n;
        for(int i = m-1 ; i >= 0 ; i --)
        {
            int pa = _find(nodes[i].x);
            int pb = _find(nodes[i].y);
            if( pa != pb )
            {
                p[pa]  = pb;
                a[i] = ans--;
            }
            else
                a[i] = ans;
        }
        for(int i = 0 ; i < m ; i ++)
            printf("%lld\n",a[i]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值