After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 1 0 5 ) N (≤10^5) N(≤105), which is the number of testees. Then N N N lines follow, each gives the information of a testee in the following format:
ID Score School
where ID
is a string of 6 characters with the first one representing the test level: B
stands for the basic level, A
the advanced level and T
the top level; Score
is an integer in [0, 100]; and School
is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID
is unique for each testee.
Output Specification:
For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:
Rank School TWS Ns
where Rank
is the rank (start from 1) of the institution; School
is the institution code (all in lower case); TWS
is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5
, where ScoreX
is the total score of the testees belong to this institution on level X
; and Ns
is the total number of testees who belong to this institution.
The institutions are ranked according to their TWS
. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns
. If there is still a tie, they shall be printed in alphabetical order of their codes.
Sample Input:
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu
Sample Output:
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2
Solution:
// Talk is cheap, show me the code
// Created by Misdirection 2021-08-29 22:06:54
// All rights reserved.
#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>
using namespace std;
struct School{
string name;
int ns;
int sumB, sumA, sumT;
int tws;
School(string n){
name = n;
ns = 0;
sumB = sumA = sumT = 0;
tws = -1;
}
~School(){}
};
bool cmp(School &a, School &b){
if(a.tws != b.tws) return a.tws > b.tws;
if(a.ns != b.ns) return a.ns < b.ns;
return a.name < b.name;
}
int main(){
int n;
scanf("%d", &n);
unordered_map<string, bool> hasAppeared;
unordered_map<string, int> position;
vector<School> schools;
string id, school;
int score;
for(int i = 0; i < n; ++i){
cin >> id >> score >> school;
transform(school.begin(), school.end(), school.begin(), ::tolower);
if(hasAppeared[school] == false){
hasAppeared[school] = true;
schools.emplace_back(school);
int pos = schools.size() - 1;
position[school] = pos;
schools[pos].ns++;
if(id[0] == 'B') schools[pos].sumB += score;
else if(id[0] == 'A') schools[pos].sumA += score;
else schools[pos].sumT += score;
}
else{
int pos = position[school];
schools[pos].ns++;
if(id[0] == 'B') schools[pos].sumB += score;
else if(id[0] == 'A') schools[pos].sumA += score;
else schools[pos].sumT += score;
}
}
for(int i = 0; i < schools.size(); ++i)
schools[i].tws = (int)(schools[i].sumB / 1.5 + schools[i].sumA + schools[i].sumT * 1.5);
sort(schools.begin(), schools.end(), cmp);
printf("%d\n", (int)schools.size());
int rank = 1;
for(int i = 0; i < schools.size(); ++i){
if(i == 0) printf("1 %s %d %d\n", schools[i].name.c_str(), schools[i].tws, schools[i].ns);
else{
if(schools[i].tws != schools[i - 1].tws) rank = i + 1;
printf("%d %s %d %d\n", rank, schools[i].name.c_str(), schools[i].tws, schools[i].ns);
}
}
return 0;
}