PTA甲级 1057 Stack (C++)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N N N elements, the median value is defined to be the ( N / 2 ) (N/2) (N/2)-th smallest element if N N N is even, or ( ( N + 1 ) / 2 ) ((N+1)/2) ((N+1)/2)-th if N N N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 1 0 5 ) N (≤10^5) N(105). Then N N N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 1 0 5 10^5 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

Caution:

一直没想到解决办法,看了柳神的代码才了解到树状数组,属实是孤陋寡闻。
代码就直接贴柳神的了(原博)。

Solution:

#include <cstdio>
#include <stack>
#define lowbit(i) ((i) & (-i))

using namespace std;

const int maxn = 100010;
int c[maxn];
stack<int> s;

void update(int x, int v) {
    for(int i = x; i < maxn; i += lowbit(i)) c[i] += v;
}

int getsum(int x) {
    int sum = 0;
    for(int i = x; i >= 1; i -= lowbit(i)) sum += c[i];

    return sum;
}

void PeekMedian() {
    int left = 1, right = maxn, mid, k = (s.size() + 1) / 2;

    while(left < right) {
        mid = (left + right) / 2;

        if(getsum(mid) >= k) right = mid;
        else left = mid + 1;
    }

    printf("%d\n", left);
}

int main() {
    int n, temp;
    scanf("%d", &n);

    char str[15];
    for(int i = 0; i < n; i++){
        scanf("%s", str);

        if(str[1] == 'u') {
            scanf("%d", &temp);
            s.push(temp);
            update(temp, 1);
        } 
        else if(str[1] == 'o'){
            if(!s.empty()){
                update(s.top(), -1);
                printf("%d\n", s.top());
                s.pop();
            }
            else printf("Invalid\n");
        } 
        else{
            if(!s.empty()) PeekMedian();
            else printf("Invalid\n");
        }
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值