你好,容斥原理---层叠消融

http://acm.hdu.edu.cn/showproblem.php?pid=1796 

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20. 

Output

  For each case, output the number.

Sample Input

12 2 2 3

Sample Output

7

 

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<cmath>
#include<string>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
//层叠消融---偶消奇不消 
ll num[11]; 
ll m,n;
ll sum=0,cnt;
ll gcd(ll a,ll b){
	return b==0?a:gcd(b,a%b);
}
ll LCM(ll a,ll b){
	return a/gcd(a,b)*b;
}

void dfs(int i,ll lcm,ll step){
	if(step&1)//如果是层叠奇数次 
		sum+=(n-1)/lcm;
	else sum-=(n-1)/lcm;//否则消去 
	for(int k=i+1;k<cnt;k++){
		dfs(k,LCM(lcm,num[k]),step+1);
	}
}

int main(){
	ll x;
	while(cin>>n>>m){
	cnt=1;
	for(int i=1;i<=m;i++){
		cin>>x;
		if(x>0&&x<n)num[cnt++]=x;
	}
	sum=0;
	for(int i=1;i<cnt;i++){
		dfs(i,num[i],1);
	}
	cout<<sum<<endl;
	}
return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值