第K大的因子

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder. 
---Wikipedia 

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.

Input

The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers X, Y and K. 

[Technical Specification] 
1. 1 <= T <= 100 
2. 1 <= X, Y, K <= 1 000 000 000 000 

Output

For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.

Sample Input

3
2 3 1
2 3 2
8 16 3

Sample Output

1
-1
2

题意:

给X,Y,K求X,Y的第k大的因子。

思路:

第k的大因子一定是X,Y的最大公因子的因子,所以我们可以先求出X,Y的因子,然后暴力枚举每一个因子(O(sqrt(n))的复杂度),如果数量比k大,排序找出,否则输出-1。

上板子,今天刚找的。

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
ll ans[2000100];
ll gcd(ll a,ll b)
{
	if(b==0)return a;
	return gcd(b,a%b);
}
ll cmp(ll a,ll b)
{
	return a>b;
}
void solve(ll x,ll k)
{
	int cnt=0;
	for(ll i=1;i*i<=x;i++)
	{
		if(x%i==0)
		{
			ans[cnt++]=i;
			if(x/i!=i)
			ans[cnt++]=x/i;
		}
	}
	if(cnt>=k)
	{
		sort(ans,ans+cnt,cmp);
		cout<<ans[k-1]<<endl;
	}
	else
	cout<<"-1"<<endl;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		ll x,y,k;
		cin>>x>>y>>k;
		ll g=gcd(x,y);
		solve(g,k);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值