PAT 1023 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题意:
1、大整数运算

2、duplication 重复 ;permutation 排列,组合;

我的代码:

#include<cstdio>
#include<cstring>
int hashtable[10] = {0},hashtemp[10] = {0};
char result[25],num[25];
int doubleit(char num[],int len)
{
    int temp = 0,cnt = 0;
    for (int i = len - 1 ;i >= 0 ;i--)
    {
        result[cnt++] = ((num[i] - '0') * 2 + temp) % 10 + '0';
        hashtemp[((num[i] - '0') * 2 + temp) % 10]++;
        temp = ((num[i] - '0') * 2 + temp) / 10;
    }
    if (temp != 0)
    {
        result[cnt++] = '1';
        hashtemp[1]++;
    }
    return cnt;
}
bool judge(int len,int len1)
{
    if (len1 != len)
        return false;
    else
    {
        for (int i  = 0 ;i < 10 ;i++)
        {
            if (hashtable[i] != hashtemp[i])
                return false;           
        }              
    }
    return true;    
}
int main()
{
    scanf("%s",num);
    int len = strlen(num);
    for (int i = 0 ;i < len ;i++)
        hashtable[num[i] - '0']++;
    int len1 = doubleit(num,len);
    if (judge(len,len1))
        printf("Yes\n");
    else
        printf("No\n");
    for (int i = len1 - 1 ; i >= 0 ;i--)
        printf("%c",result[i]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值