PAT 1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤10^4) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

分析:

1、贪心,sort里cmp的神应用,膜拜大佬柳婼;也运用了string str 里面删除单个元素用str.erase(迭代器)

2、测试点2出错是没有考虑全零的情况,要特判

我的代码:

#include<bits/stdc++.h>
using namespace std;
bool cmp(string s1,string s2)
{
    return s1 + s2 < s2 + s1;
}
int main()
{
    int n,k = 0;
    scanf("%d",&n);
    vector<string> v;
    for (int i = 0 ;i < n ;i++)
    {
        string str;
        cin >> str;
        v.push_back(str);
    }
    sort(v.begin(),v.end(),cmp);
    string str;
    for (int i = 0 ;i < v.size() ;i++)
        str += v[i];
    while (str[0] == '0')
        str.erase(str.begin());
    if (str.size() == 0)
        printf("0");
    else
        printf("%s",str.c_str());
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值