PAT甲级1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

结尾无空行

Sample Output:

22932132143287

结尾无空行

/*思路:字符串合并排序,最后删除前导0,如果长度为0则输出0,否则直接打印*/
#include <bits/stdc++.h>
using namespace std;
bool cmp(string a,string b) {return a+b<b+a;}
int main()
{
    int n;
    scanf("%d",&n);
    vector<string> str(n);
    string ans="";
    for(int i=0;i<n;i++) cin>>str[i];
    sort(str.begin(),str.end(),cmp);
    for(int i=0;i<str.size();i++) ans+=str[i];
    while(ans.length()>0&&ans[0]=='0') ans.erase(ans.begin());
    if(ans.length()==0) cout<<"0";
    else cout<<ans;
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
DB历史主题丢失是指数据库历史记录的主题内容不见了。这种情况下,我们可以尝试通过重新配置来恢复它。 首先,我们需要检查数据库配置文件,确保历史记录功能没有被禁用或配置错误。检查配置文件中与历史记录相关的参数设置,如历史记录的保留时间、历史记录文件的存储位置等。如果这些参数设置正确,但历史主题仍然丢失,我们可以尝试以下步骤进行恢复。 1. 停止数据库服务:首先,需要停止正在运行的数据库服务,以便执行下一步的操作。 2. 备份数据库:在进行任何恢复操作之前,务必先备份数据库文件,以防止意外数据丢失。 3. 清空历史记录相关文件:进入数据库目录,并删除与历史记录相关的文件,如历史记录日志文件、历史记录索引文件等。这样做的目的是清除之前可能存在的损坏的历史记录文件。 4. 重新配置数据库:编辑数据库配置文件,重新启用历史记录功能并确保相应的参数设置正确。 5. 启动数据库服务:保存更改后,重新启动数据库服务,让新的配置生效。 6. 监视恢复进程:在数据库启动后,我们可以通过监视日志或使用数据库管理工具,验证历史记录是否被正确恢复。可以查看历史记录是否开始重新生成,以及检查历史记录文件是否存在以及大小是否与预期一致。 7. 测试恢复结果:使用数据库客户端连接到数据库,并执行一些操作,以验证历史记录是否正常工作。可以查询历史记录文件,查看相应的操作是否已被记录。 总之,当DB历史主题丢失时,我们可以尝试通过重新配置数据库来恢复它。这个过程需要注意备份数据、重要文件的清除和重新配置以及验证恢复结果等步骤,以确保恢复过程顺利且有效。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值