[Loops]D. Liang 4.8 Finding the highest score.c

Description
Write a program that reads the number of students, each student’s score, and displays the highest score.
Input
The first line contains a positive integer n (n > 0), n is the number of students. The second line contains n positive integers seperated by one blank which are the students’ scores.
Output
The higithest score in one line. There is a newline at the end.
Sample Input
3
90 80 95
Sample Output
95

//  Date:2020/3/13
//  Author:xiezhg5 
#include <stdio.h>
#include <stdlib.h>
int main()
{
    int n,a,max,i;
    scanf("%d",&n);
    scanf("%d",&max);     //max肯定在输入的数中 
    for(i=1;i<n;i++)     //n是输入整数的个数这里是循环次数 
    {
        scanf("%d",&a);    //读入所输入的整数 
        //用循环依次比较输入的数的大小
		//并将较大的数存放在max中 
        if(a>max)max=a;   
    }
    printf("%d",max);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值