PAT甲级 1001 A+B Format (20分)

1001 A+B Format (20分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6≤a,b≤10​6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目大意:

计算 a + b的和并且按标准格式输出,这里的标准格式是指从个位开始,每隔3个数字加一个逗号(groups of three by commas )。
例如:12,345 -9,997

C++实现

#include<iostream>
using namespace std;
int main()
{
	long long a,b;
	cin>>a>>b;
	long long c=a+b;
	string s=to_string(c);//用字符串处理比较方便
	int m;
	if(s[0]=='-') 
	{
		if((s.size()-1)%3==0) m=3;//-1是把开头的负号去掉
	    else m=(s.size()-1)%3;
	}
	else
	{
	    if(s.size()%3==0) m=3;
	    else m=s.size()%3;
	}
	string ss="";
	for(int i=0;i<s.size();i++)
	{
		if(s[i]=='-') { ss+="-";continue;}//处理负号
		ss+=s[i];
		m--;
		if(m==0) {
			m=3;
			if(i==s.size()-1) continue;
			ss=ss+",";
		}
	}
	cout<<ss;
	return 0;
}

在这里插入图片描述

二刷AC代码

//参考liuchuo
#include<iostream>
using namespace std;
int main()
{
	long long a, b;
	cin >> a >> b;
	string s = to_string(a + b);
	int len = s.size();
	for(int i = 0; i < len; i++){
		cout<<s[i];
		if(s[i] == '-'){
			continue;
		}
		//在合适的地方输出逗号,根据规律得出(i+1) % 3 == len % 3 并且i不是最后一个下标
		if( i != len - 1 && (i+1) % 3 == len % 3) cout<<',';
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值