自测-4 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

挺难的,我感觉。要我说这题像我也只有上网找找思路先,谁能想到最后2个测试点超过long long了呢,所以只能用字符串了(想当初我一把心酸泪洒在了整形数据上,却发现根本不够塞牙缝…)。

进位的做法和我以前做的时间表示题类似。

上代码:

#include <stdio.h>
#include <string.h>
int main()
{/*特别注意这三个数组一定一定一定要初始化!!!要不然会产生输出随机数
要是问我是怎么发现的(每个数组我一个一个循环输出,看出来的...)*/
    int a[50] = {0}, a1[50] = {0}, b[50] = {0}, i, t, flag = 1,   tag = 0;
    char s[50];
    scanf("%s", s);

    for (i = 0; s[i] != '\0'; i++)
    {
        t = s[i] - '0';
        b[i] = t * 2;
        a[t]++;
    }
    for (i = strlen(s) - 1; i >= 0; i--)
    {
        if (b[i] > 9 && i > 0)
        {
            b[i] -= 10;
            b[i - 1]++;
        }
        if (b[0] > 9)
        {
            tag = 1;/*如果第一个数b[0]大于9,那么后面计数的时候需要特殊处理下哦*/
        }
    }
    if (tag)
    {
        for (i = 1; i < strlen(s); i++)
        {
            a1[b[i]]++;
        }
        t = b[0];
        a1[t % 10]++;
        t /= 10;
        a1[t % 10]++;
    }
    else
    {
        for (i = 0; i < strlen(s); i++)
        {
            a1[b[i]]++;
        }
    }/* if-else 计数模块哦*/

    for (i = 0; i <= 9; i++)
    {
        if (a[i] != a1[i])
        {
            flag = 0;
            break;
        }
    }/*判断模块哦*/
    if (flag)
    {
        printf("Yes\n");
        for (i = 0; i < strlen(s); i++)
        {
            printf("%d", b[i]);
        }
    }
    else
    {
        printf("No\n");
        for (i = 0; i < strlen(s); i++)
        {
            printf("%d", b[i]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

thoroughly strive

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值