01背包

题:
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.

Output
For each test case, output one integer, indicating maximum value iSea could get.

Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3
Sample Output
5
11

题意:有N个商品,Pi为价格,所剩的钱少于Qi则商家拒绝交易,Vi为商品价值。
求可获得的最高价值。
多组输入。
第一行输入N(项目编号)、M(初始金额)。
(1≤N≤500、1≤M≤5000)
然后是N行,每行包含三个数字Pi,Qi和Vi(1≤Pi≤Qi≤100,1≤Vi≤1000)。

#include<iostream>
#include<cstring>
#include<algorithm>
#define N 505
#define M 5005
using namespace std;

int B[N][M];

struct sss{
	int p;	//商品价钱   (商品占据的背包容量) 
	int q;	//本金低于此则拒绝交易  (剩余背包容量低于此则无法囊括) 
	int v;	//自己估价 		(实际的价值,求价值最大) 
	int s;	//性价比:需要的钱减去花费的钱 
}o[N];
	
	
bool cmp(sss a,sss b)
{
	return a.s<b.s;
}

void knapsack(int n,int m)	//n 商品数量  m 自己的钱 (总背包容量) 
{
	int k,c;
	for(k=1;k<=n;++k)
	{
		for(c=1;c<=m;++c)
		{
			if(o[k].q>c)
			{
				B[k][c]=B[k-1][c];
			}
			else
			{
				int value1=B[k-1][c-o[k].p]+o[k].v;
				int value2=B[k-1][c];
				if(value1>value2)
				{
					B[k][c]=value1;
				}
				else
				{
					B[k][c]=value2;
				}
			}
		}
	}
}

int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		memset(B,0,sizeof(B));
		for(int i=1;i<=n;++i)
		{
			cin>>o[i].p>>o[i].q>>o[i].v;
			o[i].s=o[i].q-o[i].p;
		}
		sort(o+1,o+n+1,cmp);
		knapsack(n,m);
		cout<<B[n][m]<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值